From version 138.3
edited by Vincent Massol
on 2019/01/30
To version 139.1
edited by Vincent Massol
on 2019/04/18
Change comment: Try to be more precise for java requirements

Summary

Details

Page properties
Content
... ... @@ -14,7 +14,13 @@
14 14  
15 15  = Hardware and Software requirements =
16 16  
17 -* Java 1.8.0_101 or greater installed for XWiki >= 8.1 (Java 7 or greater for XWiki < 8.1, Java 6 or greater for XWiki versions < 6.0). {{warning}}For the moment we don't recommend running on Java 9+ since we're still testing it and fixing issues. If you really insist on Java 9+, make sure to use the latest released version of XWiki!{{/warning}}.
17 +* Minimal Java versions
18 +** Java 1.8.0_101 or greater installed for XWiki >= 8.1
19 +** Java 7 for XWiki < 8.1,
20 +** Java 6 for XWiki versions < 6.0).
21 +* Maximal Java versions
22 +** Java 8 for XWiki < 11.3
23 +** Java 11 for XWiki >= 11.3 {{warning}}We're still testing this. Please let us know if you encounter any issue. Note that we have not started testing Java 12{{/warning}}
18 18  * A Servlet Container supporting Servlet 3.0.1 (Servlet 2.4 for XWiki versions < 7.0). Check the [[Servlet Containers officially supported by XWiki devs>>dev:Community.ServletContainerSupportStrategy.WebHome]].
19 19  * A Database and a JDBC 4 Driver for your database (JDBC 3 was required for XWiki versions < 7.0). Check the [[databases offically supported by XWiki devs>>dev:Community.DatabaseSupportStrategy]].
20 20  * A supported browser to access XWiki. Check the [[browsers offically supported by XWiki devs>>dev:Community.BrowserSupportStrategy]].

Get Connected