From version < 131.3 >
edited by Vincent Massol
on 2018/10/04
To version < 132.1 >
edited by Vincent Massol
on 2018/10/31
< >
Change comment: There is no comment for this version

Summary

Details

Page properties
Content
... ... @@ -15,11 +15,12 @@
15 15  = Hardware and Software requirements =
16 16  
17 17  * Java 1.8.0_101 or greater installed for XWiki >= 8.1 (Java 7 or greater for XWiki < 8.1, Java 6 or greater for XWiki versions < 6.0). {{warning}}For the moment we don't recommend running on Java 9+ since we're still testing it and fixing issues. If you really insist on Java 9+, make sure to use the latest released version of XWiki!{{/warning}}.
18 -* A Servlet Container supporting Servlet 3.0.1 (Servlet 2.4 for XWiki versions < 7.0)
19 -* A Database and a JDBC 4 Driver for your database (JDBC 3 was required for XWiki versions < 7.0)
18 +* A Servlet Container supporting Servlet 3.0.1 (Servlet 2.4 for XWiki versions < 7.0). Check the [[Servlet Containers officially supported by XWiki devs>>dev:Community.ServletContainerSupportStrategy.WebHome]].
19 +* A Database and a JDBC 4 Driver for your database (JDBC 3 was required for XWiki versions < 7.0). Check the [[databases offically supported by XWiki devs>>dev:Community.DatabaseSupportStrategy]].
20 +* A supported browser to access XWiki. Check the [[browsers offically supported by XWiki devs>>dev:Community.BrowserSupportStrategy]].
20 20  * Enough memory, check the [[Memory section>>Documentation.AdminGuide.Performances.WebHome#HMemory]] of the [[Performance Guide>>Documentation.AdminGuide.Performances.WebHome]].
21 21  * Enough [[CPU and RAM>>Documentation.AdminGuide.Performances.WebHome#HSizing]]
22 -* Check the [[release notes>>xwiki:ReleaseNotes.WebHome]] for the version you're installing to see what browsers and databases are supported for it, and to see specific requirements/installation steps. You can also check our [[general support strategy>>dev:Community.SupportStrategy]].
23 +* Check the [[release notes>>xwiki:ReleaseNotes.WebHome]] for the version you're installing to see what browsers and databases have been tested for it, and to see specific requirements/installation steps. You can also check our [[general support strategy>>dev:Community.SupportStrategy]].
23 23  
24 24  = Installation Methods =
25 25  

Get Connected