The aim of this report is to test XWiki 11.6.1 and see that everything is working properly.

Tested Browsers & Databases

Here is the list of browsers we support and how they have been tested for this release:

 BrowserTests performed and results
Chrome30.pngGoogle Chrome 76Jira Tickets Marked as Fixed in the Release Notes + Smoke tests
Firefox30.pngMozilla Firefox 68Not Tested
Edge30.pngMicrosoft Edge 18Not Tested
IE30.pngInternet Explorer 11Not Tested
Safari30.pngSafari 12Not Tested

Here is the list of databases we support and how they have been tested for this release:

 DatabaseTests performed and results
hypersql.pngHyperSQL 2.5.0Not Tested
mysql.pngMySQL 5.7Not Tested
oracle.pngOracle 12cNot Tested
postgresql.pngPostgreSQL 11Jira Tickets Marked as Fixed in the Release Notes + Smoke tests

Here is the list of Servlet Containers we support and how they have been tested for this release:

 Servlet ContainerTests performed and results
tomcat-icon.pngTomcatNot Tested
jetty-icon.pngJetty (XWiki Standalone packaging)Jira Tickets Marked as Fixed in the Release Notes + Smoke tests
jetty-icon.pngJettyNot Tested

Jira Tickets Marked as Fixed in the Release Notes

Release Notes

TicketBrowserTest ResultTested by
Closed XWIKI-16653 Notifications REST should only be installed on root namespace-Not Tested
Closed XWIKI-16652 Mail send default extension should only be installed on root namespace-Not Tested
Closed XWIKI-16649 AbstractDocumentConfigurationSource does not destroy the cache when it's disposed-Not Tested
Closed XWIKI-16648 NotificationEventExecutor does not destroy the caches it create when it's disposed-Not Tested
Closed XWIKI-16644 Symbolic link from etc/xwiki/xwiki-locales.txt to /usr/lib/xwiki/WEB-INF is missing-Not Tested
Closed XWIKI-16642 Async Macro should have a 'Content' field in the WYSIWYGChrome 75PassIlie 1
Closed XWIKI-16641 Errors when inserting Async Macro preventing it from being displayedChrome 75PassIlie 1
Closed XWIKI-16640 Possible NPE when using nested wikimacroChrome 75PassIlie 1
Closed XWIKI-16630 Tomcat 9 based Debian package still depends on tomcat8-Not Tested
-Not Tested
-Not Tested
-Not Tested

1 Regarding Closed XWIKI-16642, Closed XWIKI-16641 and Closed XWIKI-16640, it could not be tested on IE11 due to .

Tags:
Created by Ilie Andriuta on 2019/08/09
   

Get Connected